summaryrefslogtreecommitdiff
path: root/hw/kdrive/ephyr/Makefile.am
diff options
context:
space:
mode:
authorDodji Seketeli <dodji@openedhand.com>2007-08-14 22:48:41 +0200
committerDodji Seketeli <dodji@openedhand.com>2007-10-02 16:55:14 +0200
commite4239a48075c77e6a8d2d5cb21f58dd67687482f (patch)
tree821364d77f5c6ae4370bf04cec866f2a594db66b /hw/kdrive/ephyr/Makefile.am
parente01d3dd98d1b596e75d25f94dd89c7d41223011d (diff)
Initial dri forwarding big bricks.
* hw/kdrive/ephyr/ephyrdriext.c: added this to implement a DRI extension into Xephyr. Normally the DRI extension is only present in the xfree86 server, but I have ported it to Xephyr. The extension calls functions that declared/defined in ephyrdri.h ephyrdri.c that forwards the DRI calls to the host X. It does not work yet, as this entry is just to put the big bricks in place. * hw/kdrive/ephyr/ephyrdri.c,h: declaration & definition of the DRI client API that would hit the hostX server. * hw/kdrive/ephyr/GL/internal/dri_interface.h: added this, otherwise inclusion of /usr/include/X11/dri/xf86dri.h won't compile
Diffstat (limited to 'hw/kdrive/ephyr/Makefile.am')
-rw-r--r--hw/kdrive/ephyr/Makefile.am10
1 files changed, 8 insertions, 2 deletions
diff --git a/hw/kdrive/ephyr/Makefile.am b/hw/kdrive/ephyr/Makefile.am
index 193c26bd5..290aa3409 100644
--- a/hw/kdrive/ephyr/Makefile.am
+++ b/hw/kdrive/ephyr/Makefile.am
@@ -3,7 +3,7 @@ INCLUDES = \
@KDRIVE_CFLAGS@ \
-I$(srcdir)/../../../exa
-noinst_LIBRARIES = libxephyr-hostx.a libxephyr-hostxv.a libxephyr.a
+noinst_LIBRARIES = libxephyr-hostx.a libxephyr-hostxv.a libxephyr.a
bin_PROGRAMS = Xephyr
@@ -22,11 +22,16 @@ libxephyr_a_SOURCES = \
ephyr.c \
ephyr_draw.c \
ephyrvideo.c \
+ ephyrdriext.c \
+ ephyrdri.c \
+ ephyrdri.h \
os.c \
hostx.h \
ephyr.h \
ephyrlog.h
+libxephyr_a_CFLAGS = @LIBDRM_CFLAGS@ @DRIPROTO_CFLAGS@
+
Xephyr_SOURCES = \
ephyrinit.c
@@ -36,7 +41,8 @@ Xephyr_LDADD = \
libxephyr-hostxv.a \
../../../exa/libexa.la \
@KDRIVE_LIBS@ \
- @XEPHYR_LIBS@
+ @XEPHYR_LIBS@ \
+ @LIBDRM_LIBS@
Xephyr_DEPENDENCIES = \
libxephyr.a \