summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDaniel Stone <daniel@fooishbar.org>2008-07-17 21:39:46 +0300
committerDaniel Stone <daniel@fooishbar.org>2008-07-17 21:39:46 +0300
commit711720650cc192022f0d91f5cf94292d48dbc891 (patch)
treec8326a62566276f2e004ce6126754df84a52bd52 /configure.ac
parent446fe9eecddd1337f9d5164dd7c301e1ba3dfe32 (diff)
Everyone has urandom
If you don't have urandom, please just add a fallback to /dev/random, rather than building our own random generator.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 0 insertions, 13 deletions
diff --git a/configure.ac b/configure.ac
index 85cfff1c7..eb51c7119 100644
--- a/configure.ac
+++ b/configure.ac
@@ -176,19 +176,6 @@ dnl has it in libc), or if libdl is needed to get it.
AC_CHECK_FUNC([dlopen], [],
AC_CHECK_LIB([dl], [dlopen], DLOPEN_LIBS="-ldl"))
-case $host_os in
- linux*|darwin*)
- AC_DEFINE(HAVE_URANDOM, 1, [Has /dev/urandom]) ;;
- freebsd*|netbsd*|openbsd*|dragonfly*)
- AC_DEFINE(HAVE_URANDOM, 1, [Has /dev/urandom]) ;;
- solaris*)
- # Solaris 8 with patches, or Solaris 9 or later have /dev/urandom
- if test -r /dev/urandom ; then
- AC_DEFINE(HAVE_URANDOM, 1, [Has /dev/urandom])
- fi ;;
- *) ;;
-esac
-
dnl Checks for library functions.
AC_FUNC_VPRINTF
AC_CHECK_FUNCS([geteuid getuid link memmove memset mkstemp strchr strrchr \