summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorDamien Lespiau <damien.lespiau@intel.com>2012-07-25 14:51:09 +0100
committerKristian Høgsberg <krh@bitplanet.net>2012-07-25 10:40:11 -0400
commitea40bf88bce04fb212cc946d8e006d2731a5d944 (patch)
treec63877ac6e23f38c4c2cc33d06b50e39a9e51649 /tests/Makefile.am
parente302b3ef77894cb9fd4113c873a5502efc9a8dd6 (diff)
tests: Use pkg-config to find setbacklight CFLAGS and libs
setbacklight depends on udev and drm, one cannot just add the -l flags if you want to support unusual install paths.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index b788977a..1f5514fc 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -35,6 +35,7 @@ setbacklight_SOURCES = \
$(top_srcdir)/src/libbacklight.c \
$(top_srcdir)/src/libbacklight.h
-setbacklight_LDADD = -ludev -ldrm
+setbacklight_CFLAGS = $(AM_CFLAGS) $(SETBACKLIGHT_CFLAGS)
+setbacklight_LDADD = $(SETBACKLIGHT_LIBS)
EXTRA_DIST = weston-test