summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorKristian Høgsberg <krh@bitplanet.net>2012-04-27 15:02:56 -0400
committerKristian Høgsberg <krh@bitplanet.net>2012-04-27 15:03:06 -0400
commit3018b4431bc57b2ce3faae69e919ff713064873c (patch)
treeddc9e03393fb67c1ddd3adb4e574d8d55d6d96c9 /tests/Makefile.am
parentdd90921d878c9d2ace742091f81684a3db72a5ff (diff)
tests: Add event-test, which tests for a few incoming events
We check that we get surface.enter_output and move the pointer into the window and make sure we get input_device.pointer_enter with the right coordinates. There's a lot of code for a very simple test here, so we need to figure out how to reuse most of the event handling and such. It's also not clear that a custom, text based protocol is practical here, we might just use a wayland extension after all.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index d4684941..fe9698f4 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -1,4 +1,4 @@
-TESTS = surface-test.la client-test.la
+TESTS = surface-test.la client-test.la event-test.la
TESTS_ENVIRONMENT = $(SHELL) $(top_srcdir)/tests/weston-test
@@ -17,6 +17,7 @@ test_runner_src = test-runner.c test-runner.h
surface_test_la_SOURCES = surface-test.c $(test_runner_src)
client_test_la_SOURCES = client-test.c $(test_runner_src)
+event_test_la_SOURCES = event-test.c $(test_runner_src)
test_client_SOURCES = test-client.c
test_client_LDADD = $(SIMPLE_CLIENT_LIBS)