summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorTiago Vignatti <tiago.vignatti@intel.com>2013-02-08 14:57:00 +0200
committerKristian Høgsberg <krh@bitplanet.net>2013-02-08 12:18:05 -0500
commit19dadf26171c18d9ad1e96c523a0e0dabd673d20 (patch)
treec0d318cb754c9d3b005031ee6c54c53123bcd11c /tests/Makefile.am
parent314d988b280b28bdebe12f5dae931e355c7c7ca1 (diff)
tests: Add XWayland test
By default enabled but one can disable it by passing --disable-xwayland-test to the configure script. Also, the weston-tests-env script is trying to load xwayland.so in either case, but it behaves resilient in the absence of that meaning all the other tests are still going to be kicked for running. Signed-off-by: Tiago Vignatti <tiago.vignatti@intel.com>
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am11
1 files changed, 10 insertions, 1 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 7d6b6e04..11cd4ecd 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -8,7 +8,8 @@ weston_tests = \
keyboard-test \
event-test \
button-test \
- text-test
+ text-test \
+ $(xwayland_test)
TESTS_ENVIRONMENT = $(SHELL) $(top_srcdir)/tests/weston-tests-env
@@ -74,6 +75,14 @@ text_test_SOURCES = \
$(weston_test_client_src)
text_test_LDADD = $(weston_test_client_libs)
+xwayland_test_SOURCES = xwayland-test.c $(weston_test_client_src)
+
+xwayland_test_LDADD = $(weston_test_client_libs) $(XWAYLAND_TEST_LIBS)
+
+if ENABLE_XWAYLAND_TEST
+xwayland_test = xwayland_test
+endif
+
matrix_test_SOURCES = \
matrix-test.c \
$(top_srcdir)/shared/matrix.c \