summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNeil Roberts <neil@linux.intel.com>2013-10-29 20:13:45 +0000
committerKristian Høgsberg <krh@bitplanet.net>2013-12-07 22:26:23 -0800
commit40c0c3f91eeb747b86df64579e3b3706cc5450af (patch)
tree6cb7746f09c17951a2aa67ad7385c60295c51fa2 /configure.ac
parent65a07f8aef9538602792b33cb33fe856708173c0 (diff)
tests: Test whether a simple EGL main loop uses too many buffers
This adds a test that tries to simulate a simple game loop that would be like this: while (1) { draw_something(); eglSwapBuffers(); } In this case the test is relying on eglSwapBuffers to throttle to a sensible frame rate. The test then verifies that only 2 EGL buffers are used. This is done via a new request and event in the wayland-test protocol. Currently this causes 3 buffers to be created because the release event generated by the swap buffers is not processed by Mesa until it blocks for the frame complete event in the next swap buffers call, but that is too late. This can be fixed in Mesa by issuing a sync request after the swap buffers and blocking on it before deciding whether to allocate a new buffer.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 86940d5d..8baef885 100644
--- a/configure.ac
+++ b/configure.ac
@@ -65,6 +65,7 @@ AM_CONDITIONAL(ENABLE_EGL, test x$enable_egl = xyes)
if test x$enable_egl = xyes; then
AC_DEFINE([ENABLE_EGL], [1], [Build Weston with EGL support])
PKG_CHECK_MODULES(EGL, [egl >= 7.10 glesv2])
+ PKG_CHECK_MODULES([EGL_TESTS], [egl >= 7.10 glesv2 wayland-client wayland-egl])
fi
AC_ARG_ENABLE(xkbcommon,