summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorKonno, Joe <joe.konno@linux.intel.com>2013-01-30 07:38:57 -0800
committerKristian Høgsberg <krh@bitplanet.net>2013-02-07 21:20:07 -0500
commit314d988b280b28bdebe12f5dae931e355c7c7ca1 (patch)
tree17b1e679d229c2b03e222eda6cf538f17b213f4f /configure.ac
parent209e8f177ac9cdc649e9c465571c1c2525e82190 (diff)
configure: prevent premature HAVE_GLU check
When cairo-gl and mesa-glu are present on the system, autoconf successfully recognizes both. However, I was wondering why weston-screensaver was not building since autoconf reported all dependencies were met. Move the mesa-glu PKG_CHECK before the conditional. Additionally, remove redundant check for enable_egl, as it is implied when GLU is 'yes.' Signed-off-by: Joe Konno <joe.konno@intel.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index f3ad9dcc..d626f727 100644
--- a/configure.ac
+++ b/configure.ac
@@ -230,10 +230,10 @@ if test x$enable_weston_launch == xyes; then
WESTON_LAUNCH_LIBS="$WESTON_LAUNCH_LIBS -lpam"
fi
-AM_CONDITIONAL(HAVE_GLU, test "x$have_glu" = "xyes" -a "$xenable_egl" = "xyes")
if test x$enable_egl = xyes; then
PKG_CHECK_MODULES(GLU, [glu], [have_glu=yes], [have_glu=no])
fi
+AM_CONDITIONAL(HAVE_GLU, test "x$have_glu" = "xyes")
AM_CONDITIONAL(HAVE_POPPLER, test "x$have_poppler" = "xyes")