summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAnder Conselvan de Oliveira <ander.conselvan.de.oliveira@intel.com>2012-10-29 18:19:24 +0200
committerKristian Høgsberg <krh@bitplanet.net>2012-11-08 16:56:25 -0500
commit11f8d403a8484f0bcb9138b950f3cdf658f5d554 (patch)
tree05adcf57818354467d89a5a6d242783f987eef80 /configure.ac
parent1f1b39792baba0c808df697a3792514514a84b46 (diff)
Add a headless backend
Add a headless backend and a noop renderer, mainly for testing purposes. Although no rendering is performed with this backend, this allow some of the code paths inside Weston and shm clients to be tested without any windowing system or any need for drm access.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 35a80972..7d403cf1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -109,6 +109,12 @@ if test x$enable_wayland_compositor = xyes; then
fi
+AC_ARG_ENABLE(headless-compositor, [ --enable-headless-compositor],,
+ enable_headless_compositor=yes)
+AM_CONDITIONAL(ENABLE_HEADLESS_COMPOSITOR,
+ test x$enable_headless_compositor = xyes)
+
+
AC_ARG_ENABLE(android-compositor,
AS_HELP_STRING([--disable-android-compositor],
[do not build-test the Android 4.0 backend]),,