summaryrefslogtreecommitdiff
path: root/XTrap/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'XTrap/Makefile.am')
-rw-r--r--XTrap/Makefile.am10
1 files changed, 8 insertions, 2 deletions
diff --git a/XTrap/Makefile.am b/XTrap/Makefile.am
index 1eddd4f56..2d8a5f787 100644
--- a/XTrap/Makefile.am
+++ b/XTrap/Makefile.am
@@ -1,5 +1,11 @@
-noinst_LTLIBRARIES = libxtrap.la
+noinst_LTLIBRARIES = libxtrap.la libxtrapmodule.la
-AM_CFLAGS = $(DIX_CFLAGS)
+AM_CFLAGS = $(DIX_CFLAGS) @LOADER_DEFINES@
libxtrap_la_SOURCES = xtrapddmi.c xtrapdi.c xtrapdiswp.c xtrapditbl.c
+
+libxtrapmodule_la_CFLAGS = \
+ $(AM_CFLAGS) \
+ @MODULE_DEFINES@ \
+ -I$(top_srcdir)/hw/xfree86/os-support
+libxtrapmodule_la_SOURCES = xtrapddmi.c xtrapdi.c xtrapdiswp.c xtrapditbl.c