summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMark Lobodzinski <mark@lunarg.com>2015-11-26 10:59:58 -0700
committerJon Ashburn <jon@lunarg.com>2015-12-01 10:26:05 -0700
commit6f92feb2a1e8dded4a79b00d64ab36490b197581 (patch)
tree3a715ddba4202b96a18e78850ae1de19b5bc4418 /CMakeLists.txt
parent1ead357a510623a84f190aef2902df2ca4bd42c4 (diff)
wsi: Various fixes and Windows build issues
Diffstat (limited to 'CMakeLists.txt')
-rwxr-xr-x[-rw-r--r--]CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b3234f28..9510e31d 100644..100755
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -5,12 +5,14 @@ cmake_minimum_required(VERSION 2.8.11)
project (VULKAN)
# set (CMAKE_VERBOSE_MAKEFILE 1)
+
+
# The MAJOR number of the version we're building, used in naming
# vulkan-<major>.dll (and other files).
set(MAJOR "0")
if(WIN32)
- add_definitions(-DVK_USE_PLATFORM_WIN32_KHR)
+ add_definitions(-DVK_USE_PLATFORM_WIN32_KHR -DWIN32_LEAN_AND_MEAN)
else()
add_definitions(-DVK_USE_PLATFORM_XCB_KHR)
endif()