summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorReid Kleckner <rnk@google.com>2015-08-11 21:24:59 +0000
committerReid Kleckner <rnk@google.com>2015-08-11 21:24:59 +0000
commit3b61d133a667472b6023d7a347e36be37720a9ca (patch)
tree6bf385773210ea7e4b290cbeedd7ce3070e11b2c /CMakeLists.txt
parentab45e88378d471f97bd440623b30b28f7b643f49 (diff)
[lit] Don't disable the lit progress bar by default with MSVC
Only disable the progress bar when we're generating VS project files, like we do for XCode. This makes lit use the simple, non-curses progress bar that looks like this with: Testing: 0 .. 10.. 20.. 30.. 40.. 50.. 60.. 70.. 80.. 90.. Testing Time: 5.87s git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@244674 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 7aefb2d8f99..85176fa2058 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -309,7 +309,7 @@ endif()
# Define the default arguments to use with 'lit', and an option for the user to
# override.
set(LIT_ARGS_DEFAULT "-sv")
-if (MSVC OR XCODE)
+if (MSVC_IDE OR XCODE)
set(LIT_ARGS_DEFAULT "${LIT_ARGS_DEFAULT} --no-progress-bar")
endif()
set(LLVM_LIT_ARGS "${LIT_ARGS_DEFAULT}" CACHE STRING "Default options for lit")