summaryrefslogtreecommitdiff
path: root/tools/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tools/Makefile.am')
-rw-r--r--tools/Makefile.am15
1 files changed, 4 insertions, 11 deletions
diff --git a/tools/Makefile.am b/tools/Makefile.am
index 77b4e74..68d1fd4 100644
--- a/tools/Makefile.am
+++ b/tools/Makefile.am
@@ -1,4 +1,4 @@
-noinst_PROGRAMS = event-debug ptraccel-debug
+noinst_PROGRAMS = ptraccel-debug
bin_PROGRAMS = libinput-list-devices libinput-debug-events libinput
AM_CPPFLAGS = -I$(top_srcdir)/include \
@@ -11,13 +11,6 @@ shared_sources = \
shared.c \
shared.h
-event_debug_sources = libinput-debug-events.c $(shared_sources)
-event_debug_SOURCES = libinput-debug-events.c $(shared_sources)
-event_debug_LDADD = ../src/libinput.la $(LIBUDEV_LIBS) $(LIBEVDEV_LIBS)
-event_debug_LDFLAGS = -no-install
-event_debug_CFLAGS = $(AM_CFLAGS) $(LIBUDEV_CFLAGS) $(LIBEVDEV_CFLAGS) \
- -DTOOLS_BUILD_STANDALONE=1
-
ptraccel_debug_SOURCES = ptraccel-debug.c
ptraccel_debug_LDADD = ../src/libfilter.la ../src/libinput.la
ptraccel_debug_LDFLAGS = -no-install
@@ -28,9 +21,9 @@ libinput_list_devices_CFLAGS = $(AM_CFLAGS) $(LIBUDEV_CFLAGS) $(LIBEVDEV_CFLAGS)
-DTOOLS_BUILD_STANDALONE=1
dist_man1_MANS = libinput-list-devices.1
-libinput_debug_events_SOURCES = $(event_debug_SOURCES)
-libinput_debug_events_LDADD = $(event_debug_LDADD)
-libinput_debug_events_CFLAGS = $(AM_CFLAGS) $(event_debug_CFLAGS) \
+libinput_debug_events_SOURCES = libinput-debug-events.c $(shared_sources)
+libinput_debug_events_LDADD = ../src/libinput.la $(LIBUDEV_LIBS) $(LIBEVDEV_LIBS)
+libinput_debug_events_CFLAGS = $(AM_CFLAGS) $(LIBUDEV_CFLAGS) $(LIBEVDEV_CFLAGS) \
-DTOOLS_BUILD_STANDALONE=1
dist_man1_MANS += libinput-debug-events.1