summaryrefslogtreecommitdiff
path: root/tools/Makefile.am
diff options
context:
space:
mode:
authorPeter Hutterer <peter.hutterer@who-t.net>2014-01-28 11:25:40 +1000
committerPeter Hutterer <peter.hutterer@who-t.net>2014-01-31 14:57:19 +1000
commit3444b29ceb47694fc3a1d0e3c3588376cd79354c (patch)
treecb91769b2b7a1e808991ef23fcc3cac7500b811a /tools/Makefile.am
parent20416ae4b70ba439290dd85d5c43f5c18b224182 (diff)
tools: add a tool for basic event debugging
Simply prints the various events to make it easier to check what's coming out of libinput. Works for --udev (the default) or for --device /dev/input/event0. Example output: event7 DEVICE_ADDED seat0 default event8 DEVICE_ADDED seat0 default event4 POINTER_BUTTON +1.35s 272 pressed event5 POINTER_MOTION +2.31s -3.00/ 2.00 Time is displayed relative to the starting time. Note: statically linked for easier debugging, but we don't distribute it (yet) anyway. Signed-off-by: Peter Hutterer <peter.hutterer@who-t.net> Reviewed-by: Jonas Ã…dahl <jadahl@gmail.com>
Diffstat (limited to 'tools/Makefile.am')
-rw-r--r--tools/Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/tools/Makefile.am b/tools/Makefile.am
new file mode 100644
index 0000000..9c29f56
--- /dev/null
+++ b/tools/Makefile.am
@@ -0,0 +1,7 @@
+noinst_PROGRAMS = event-debug
+
+AM_CPPFLAGS = -I$(top_srcdir)/src
+
+event_debug_SOURCES = event-debug.c
+event_debug_LDADD = ../src/libinput.la
+event_debug_LDFLAGS = -static