summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPeter Hutterer <peter.hutterer@who-t.net>2016-11-14 09:51:46 +1000
committerPeter Hutterer <peter.hutterer@who-t.net>2016-11-14 09:59:05 +1000
commitba75b56c748afe25cd0cd63768aff3ee57012b1f (patch)
tree0d94bed562d3bf5365d75d37bafc86a86d28ea47 /configure.ac
parent8616cc0bb9d483a8ef5955e1880e78f00a8f4746 (diff)
configure.ac: move all AM_CONDITIONALs into one place
Makes it easier to see in one go what is conditional in the build. Signed-off-by: Peter Hutterer <peter.hutterer@who-t.net> Reviewed-by: Hans de Goede <hdegoede@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 43db9bb..012ab0b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -159,7 +159,6 @@ if test "x$build_eventgui" = "xyes"; then
PKG_CHECK_MODULES(CAIRO, [cairo])
PKG_CHECK_MODULES(GTK, [glib-2.0 gtk+-3.0])
fi
-AM_CONDITIONAL(BUILD_EVENTGUI, [test "x$build_eventgui" = "xyes"])
AC_ARG_ENABLE(tests,
AS_HELP_STRING([--enable-tests], [Build the tests (default=auto)]),
@@ -199,7 +198,6 @@ if test "x$build_tests" = "xyes"; then
AC_DEFINE_UNQUOTED(ADDR2LINE, ["$ADDR2LINE"], [Path to addr2line])
fi
fi
-AM_CONDITIONAL(HAVE_LIBUNWIND, [test "x$HAVE_LIBUNWIND" = xyes])
AC_ARG_ENABLE(libwacom,
AS_HELP_STRING([--enable-libwacom],
@@ -227,12 +225,14 @@ if test "x$use_libwacom" = "xyes"; then
LIBS=$OLD_LIBS
CFLAGS=$OLD_CFLAGS
fi
+
AM_CONDITIONAL(HAVE_LIBWACOM_GET_PAIRED_DEVICE,
[test "x$libwacom_have_get_paired_device" == "xyes"])
-
AM_CONDITIONAL(HAVE_VALGRIND, [test "x$VALGRIND" != "x"])
AM_CONDITIONAL(BUILD_TESTS, [test "x$build_tests" = "xyes"])
AM_CONDITIONAL(BUILD_DOCS, [test "x$build_documentation" = "xyes"])
+AM_CONDITIONAL(HAVE_LIBUNWIND, [test "x$HAVE_LIBUNWIND" = xyes])
+AM_CONDITIONAL(BUILD_EVENTGUI, [test "x$build_eventgui" = "xyes"])
# Used by the udev rules so we can use callouts during testing without
# installing everything first. Default is the empty string so the installed