summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPeter Hutterer <peter.hutterer@who-t.net>2015-03-09 15:43:39 +1000
committerPeter Hutterer <peter.hutterer@who-t.net>2015-03-09 15:43:39 +1000
commitb7e2853c8291b200e734b26d2cf0eea07acac7e6 (patch)
tree45611eb23d50780fbf11f213e92af0dbad572e7f /configure.ac
parent0021600ab93d25ed43d9037cfae5c3e23f44fbfe (diff)
parent11cec1685206efe02f6146cde15496d3dceab448 (diff)
Merge branch 'master' into tablet-support
Conflicts: src/libinput.sym
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 8 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index c09dc4e..85db1fd 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,7 +1,7 @@
AC_PREREQ([2.64])
m4_define([libinput_major_version], [0])
-m4_define([libinput_minor_version], [11])
+m4_define([libinput_minor_version], [12])
m4_define([libinput_micro_version], [0])
m4_define([libinput_version],
[libinput_major_version.libinput_minor_version.libinput_micro_version])
@@ -25,12 +25,13 @@ AM_INIT_AUTOMAKE([1.11 foreign no-dist-gzip dist-xz])
# Before making a release, the LIBINPUT_LT_VERSION string should be
# modified.
# The string is of the form C:R:A.
-# - If interfaces have been changed or added, but binary compatibility has
-# been preserved, change to C+1:0:A+1
-# - If binary compatibility has been broken (eg removed or changed interfaces)
-# change to C+1:0:0
-# - If the interface is the same as the previous version, change to C:R+1:A
-LIBINPUT_LT_VERSION=9:0:2
+# a) If binary compatibility has been broken (eg removed or changed interfaces)
+# change to C+1:0:0. DO NOT DO THIS! Use symbol versioning instead and
+# do b) instead.
+# b) If interfaces have been changed or added, but binary compatibility has
+# been preserved, change to C+1:0:A+1
+# c) If the interface is the same as the previous version, change to C:R+1:A
+LIBINPUT_LT_VERSION=10:0:0
AC_SUBST(LIBINPUT_LT_VERSION)
AM_SILENT_RULES([yes])