summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPeter Hutterer <peter.hutterer@who-t.net>2016-11-14 09:35:56 +1000
committerPeter Hutterer <peter.hutterer@who-t.net>2016-11-14 10:14:02 +1000
commit17c0049d24b2fdccb6136441b4b4c3e8e351bdee (patch)
tree25e703a181f66b06ca394ec1f4a1f22eded9d325 /configure.ac
parentdae10bca6778ba919bc384366ebd43179470d36c (diff)
Disable test runs on 'distcheck'
The tests require the creation of udev devices which in turn require root and usually cause distcheck runs to fail. Add a new option to disable the *running* of tests at distcheck (we still want to build them). Signed-off-by: Peter Hutterer <peter.hutterer@who-t.net> Reviewed-by: Hans de Goede <hdegoede@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 206a4ed..a70f4be 100644
--- a/configure.ac
+++ b/configure.ac
@@ -211,6 +211,11 @@ if test "x$build_tests" = "xyes"; then
fi
fi
+AC_ARG_ENABLE(test-run,
+ AS_HELP_STRING([--enable-test-run], [For internal use only]),
+ [run_tests="$enableval"],
+ [run_tests="yes"])
+
# Used by the udev rules so we can use callouts during testing without
# installing everything first. Default is the empty string so the installed
# rule will use udev's default path. Override is in udev/Makefile.am
@@ -220,6 +225,7 @@ AC_PATH_PROG(SED, [sed])
###########################
# enable/disable libwacom #
###########################
+
AC_ARG_ENABLE(libwacom,
AS_HELP_STRING([--enable-libwacom],
[Use libwacom for tablet identification (default=enabled)]),
@@ -251,6 +257,7 @@ AM_CONDITIONAL(HAVE_LIBWACOM_GET_PAIRED_DEVICE,
[test "x$libwacom_have_get_paired_device" == "xyes"])
AM_CONDITIONAL(HAVE_VALGRIND, [test "x$VALGRIND" != "x"])
AM_CONDITIONAL(BUILD_TESTS, [test "x$build_tests" = "xyes"])
+AM_CONDITIONAL(RUN_TESTS, [test "x$run_tests" = "xyes"])
AM_CONDITIONAL(BUILD_DOCS, [test "x$build_documentation" = "xyes"])
AM_CONDITIONAL(HAVE_LIBUNWIND, [test "x$HAVE_LIBUNWIND" = xyes])
AM_CONDITIONAL(BUILD_EVENTGUI, [test "x$build_eventgui" = "xyes"])