summaryrefslogtreecommitdiff
path: root/hw/dmx/input/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'hw/dmx/input/meson.build')
-rw-r--r--hw/dmx/input/meson.build32
1 files changed, 32 insertions, 0 deletions
diff --git a/hw/dmx/input/meson.build b/hw/dmx/input/meson.build
new file mode 100644
index 000000000..cf058adfd
--- /dev/null
+++ b/hw/dmx/input/meson.build
@@ -0,0 +1,32 @@
+srcs_dmx_input = [
+ 'dmxdummy.c',
+ 'dmxbackend.c',
+ 'dmxconsole.c',
+ 'dmxcommon.c',
+ 'dmxinputinit.c',
+ 'dmxarg.c',
+ 'dmxevents.c',
+ 'dmxxinput.c',
+ 'dmxmotion.c',
+ 'dmxmap.c',
+ 'ChkNotMaskEv.c',
+]
+
+if cc.has_header('linux/input.h')
+ srcs_dmx_input += [
+ 'usb-keyboard.c',
+ 'usb-mouse.c',
+ 'usb-other.c',
+ 'usb-common.c',
+ ]
+endif
+
+dmx_input = static_library('dmx_input',
+ srcs_dmx_input,
+ include_directories: [
+ inc,
+ include_directories('../')
+ ],
+ dependencies: common_dep,
+ c_args: '-DHAVE_DMX_CONFIG_H',
+)