summaryrefslogtreecommitdiff
path: root/present/meson.build
diff options
context:
space:
mode:
authorLouis-Francis Ratté-Boulianne <lfrb@collabora.com>2018-02-28 01:19:36 +0000
committerAdam Jackson <ajax@redhat.com>2018-03-05 13:27:32 -0500
commite2ef3b44fa697f2ed453767e98da72ea56d4046f (patch)
tree81c12224fc3def129f3aa708a5d1fa76ac3ab820 /present/meson.build
parent6e7c40f62db66f5b59b2cf59f1e6a26e4fd21bda (diff)
present: Send PresentCompleteModeSuboptimalCopy appropriately
Add 'check_flip2' hook for driver to let know the core about why flipping is not possible ('reason'). If it is because of unsupported buffer format/modifier, a PresentCompleteNotify event is sent to the client with the PresentCompleteModeSuboptimalCopy mode. v2: Check for PresentOptionSuboptimal and check driver version before using 'check_flip2'. v3: Only require one of 'check_flip' or 'check_flip2' to be implemented by the driver. Refactor reasons list to enum Signed-off-by: Louis-Francis Ratté-Boulianne <lfrb@collabora.com> Reviewed-by: Daniel Stone <daniels@collabora.com> Acked-by: Keith Packard <keithp@keithp.com> Reviewed-by: Adam Jackson <ajax@redhat.com>
Diffstat (limited to 'present/meson.build')
-rw-r--r--present/meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/present/meson.build b/present/meson.build
index a4296ca7a..cf725302a 100644
--- a/present/meson.build
+++ b/present/meson.build
@@ -13,7 +13,7 @@ libxserver_present = static_library('libxserver_present',
include_directories: inc,
dependencies: [
common_dep,
- dependency('presentproto', version: '>= 1.0')
+ dependency('presentproto', version: '>= 1.1')
],
c_args: '-DHAVE_XORG_CONFIG_H'
)