summaryrefslogtreecommitdiff
path: root/glamor/Makefile.am
diff options
context:
space:
mode:
authorGaetan Nadon <memsize@videotron.ca>2013-12-10 11:13:31 -0500
committerEric Anholt <eric@anholt.net>2013-12-18 11:23:54 -0800
commit08c23ff8aefe80f2940ecb90adda27156084f57c (patch)
tree366d61de721fb58282cec858bf0f94c83c07b2b0 /glamor/Makefile.am
parentb8055bd1f6c9dea0fe8f7a786d2a1522f5f32129 (diff)
Make: remove cruft copied over from the X server makefiles
In toplevel makefile: nostdinc: only xserver, no other X modules aclocaldir: no local macros to install xkb_path: xserver only "Gross hack": xserver only In src/makefile: SOLARIS_ASM_CFLAGS; server only XORG_INCS: undefined variable DIX_CFLAGS: undefined variable Signed-off-by: Gaetan Nadon <memsize@videotron.ca> Reviewed-by: Zhigang Gong <zhigang.gong@linux.intel.com>
Diffstat (limited to 'glamor/Makefile.am')
-rw-r--r--glamor/Makefile.am9
1 files changed, 1 insertions, 8 deletions
diff --git a/glamor/Makefile.am b/glamor/Makefile.am
index 50cfe97ea..79ea95919 100644
--- a/glamor/Makefile.am
+++ b/glamor/Makefile.am
@@ -1,19 +1,12 @@
lib_LTLIBRARIES = libglamor.la
-# Override these since glamor doesn't need them and the needed files aren't
-# built (in hw/xfree86/os-support/solaris) until after glamor is built
-SOLARIS_ASM_CFLAGS=""
-
if GLAMOR_GLES2
libglamor_la_LIBADD = $(GLESV2_LIBS)
else
libglamor_la_LIBADD = $(GL_LIBS)
endif
-AM_CPPFLAGS = \
- $(XORG_INCS)
-
-AM_CFLAGS = $(CWARNFLAGS) $(XORG_CFLAGS) $(DIX_CFLAGS) $(LIBDRM_CFLAGS)
+AM_CFLAGS = $(CWARNFLAGS) $(XORG_CFLAGS) $(LIBDRM_CFLAGS)
libglamor_la_LDFLAGS = -version-info 0:0:0