summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDaniel Stone <daniel@fooishbar.org>2008-07-16 02:59:51 +0300
committerDaniel Stone <daniel@fooishbar.org>2008-07-16 03:02:17 +0300
commitad87c72edcc0d1f56658e0c4e73af335c8d5a516 (patch)
treef67ba5ed806c326dab2db3565e734c8693943d62 /configure.ac
parentc3c901cf44cf16bb33c4176494361b429099a372 (diff)
DIX: Add strcasestr from FreeBSD
Add strcasestr for use on systems which don't have it.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 18d8ab5ff..8f2a96652 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1006,6 +1006,8 @@ AC_CHECK_FUNC(strcasecmp, [], AC_DEFINE([NEED_STRCASECMP], 1,
[Do not have 'strcasecmp'.]))
AC_CHECK_FUNC(strncasecmp, [], AC_DEFINE([NEED_STRNCASECMP], 1,
[Do not have 'strncasecmp'.]))
+AC_CHECK_FUNC(strcasestr, [], AC_DEFINE([NEED_STRCASESTR], 1,
+ [Do not have 'strcasestr'.]))
if test "x$NULL_ROOT_CURSOR" = xyes; then
AC_DEFINE(NULL_ROOT_CURSOR, 1, [Use an empty root cursor])