summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorChad Versace <chad.versace@intel.com>2011-02-23 13:35:38 -0800
committerChad Versace <chad.versace@intel.com>2011-02-25 20:42:14 -0800
commitfc493b486b8f9b85af05eb854f04bb581b94250f (patch)
treeff829d809db186e77958f409b3e31ef81013a069 /CMakeLists.txt
parentc55e20f239d3f0f960fa3e520002004cca55e0a7 (diff)
cmake: Prepare CMake for GL and GLES2 builds
Add two new CMakeLists, /cmake/target_api/{gl,gles2}/CMakeLists.txt, each of which builds Piglit with its respective API. (Of course, gles2/CMakeLists.txt adds no targets because Piglit does not yet support building with GLES2.) The toplevel CMakeLists no longer adds subdirectory /tests; that is now the responsiblity of the API-specific CMakeLists. Note: This belongs to a series that adds GLES2 support to Piglit. Signed-off-by: Chad Versace <chad.versace@intel.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 8a5ef9bd8..083cde638 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -26,8 +26,6 @@ find_library(OPENGL_gles2_LIBRARY NAMES GLESv2)
set(EXECUTABLE_OUTPUT_PATH ${piglit_BINARY_DIR}/bin)
set(LIBRARY_OUTPUT_PATH ${piglit_BINARY_DIR}/lib)
-add_subdirectory (tests)
-
check_function_exists(strchrnul HAVE_STRCHRNUL)
check_function_exists(fopen_s HAVE_FOPEN_S)
@@ -40,3 +38,5 @@ configure_file(
"${piglit_SOURCE_DIR}/tests/util/config.h.in"
"${piglit_SOURCE_DIR}/tests/util/config.h"
)
+
+add_subdirectory(cmake/target_api)