summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorDaniel Stone <daniels@collabora.com>2018-02-27 10:00:24 +0000
committerDaniel Stone <daniels@collabora.com>2018-03-20 16:18:37 +0000
commitd7603cb518cf1e0bf2c07d6ce4b139bf075b3980 (patch)
tree204e1e026db572b093a65900c8478f28b0c777cc /meson.build
parent28780c5028a60234e11e084777553ad70591f87d (diff)
meson: Add default DRI drivers for ARM/AArch64
On all Arm architectures (ARMv7 and below as 'arm', ARMv8 and above as 'aarch64'), only build swrast for DRI drivers. The only classic drivers which could be used are r200 and NV20 cards, which seems unlikely enough that it shouldn't be the default. Signed-off-by: Daniel Stone <daniels@collabora.com> Reported-by: Javier Jardón <jjardon@gnome.org> Reviewed-by: Dylan Baker <dylan@pnwbakers.com> Reviewed-by: Eric Engestrom <eric.engestrom@imgtec.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 2 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index a59736f50a..88e90fe811 100644
--- a/meson.build
+++ b/meson.build
@@ -104,6 +104,8 @@ if _drivers == 'auto'
# TODO: PPC, Sparc
if ['x86', 'x86_64'].contains(host_machine.cpu_family())
_drivers = 'i915,i965,r100,r200,nouveau'
+ elif ['arm', 'aarch64'].contains(host_machine.cpu_family())
+ _drivers = ''
else
error('Unknown architecture. Please pass -Ddri-drivers to set driver options. Patches gladly accepted to fix this.')
endif