summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEmil Velikov <emil.velikov@collabora.com>2017-03-08 23:46:06 +0000
committerEmil Velikov <emil.l.velikov@gmail.com>2017-03-13 11:16:35 +0000
commit9aebdb5d082ec640fe8a14704201952bddb50a88 (patch)
tree9879b321ba2e3a74b372b29ca4547a549a5b0b87 /configure.ac
parentee8044fd332cacff80e4afb949fe79e3733375d1 (diff)
configure.ac: do not require the i965 driver for ANV
As of last few commits we have the two split, thus we no longer require the i965 in order to have the ANV driver. Even though ANV does not link against libdrm nor libdrm_intel, we still require those as dependencies due to the headers they provide. Signed-off-by: Emil Velikov <emil.velikov@collabora.com> Reviewed-by: Jason Ekstrand <jason@jlekstrand.net>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 2 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 628aec3ceb..aa5cb75dfb 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1786,9 +1786,8 @@ if test -n "$with_vulkan_drivers"; then
for driver in $VULKAN_DRIVERS; do
case "x$driver" in
xintel)
- if test "x$HAVE_I965_DRI" != xyes; then
- AC_MSG_ERROR([Intel Vulkan driver requires the i965 dri driver])
- fi
+ require_libdrm "i965"
+ PKG_CHECK_MODULES([INTEL], [libdrm >= $LIBDRM_INTEL_REQUIRED libdrm_intel >= $LIBDRM_INTEL_REQUIRED])
HAVE_INTEL_VULKAN=yes
;;