summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorChen Ganir <chen.ganir@ti.com>2012-03-19 16:57:51 +0200
committerJohan Hedberg <johan.hedberg@intel.com>2012-03-26 12:09:51 +0300
commite407e9ac6d8bfde31f95ed5d7e7bcecf0cfe48ed (patch)
treed15d702020aa74750dc4be37c2a92f7213f79ab1 /Makefile.am
parent9c4712a9995f27c1dd7c8145ca54eb27f14af0a8 (diff)
GATT: Remove individual config switches
Remove individual GATT plugin configuration switches and add a new master gatt switch called --enable-gatt to enable/disable all GATT related plugins at once.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am38
1 files changed, 10 insertions, 28 deletions
diff --git a/Makefile.am b/Makefile.am
index bd587ebd9..ddc28d2a7 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -199,36 +199,11 @@ builtin_sources += network/main.c \
network/connection.h network/connection.c
endif
-if PROXIMITYPLUGIN
-builtin_modules += proximity
-builtin_sources += proximity/main.c \
- proximity/manager.h proximity/manager.c \
- proximity/monitor.h proximity/monitor.c \
- proximity/reporter.h proximity/reporter.c
-endif
-
if SERVICEPLUGIN
builtin_modules += service
builtin_sources += plugins/service.c
endif
-if GATT_EXAMPLE_PLUGIN
-builtin_modules += gatt_example
-builtin_sources += plugins/gatt-example.c
-endif
-
-if TIMEPLUGIN
-builtin_modules += time
-builtin_sources += time/main.c \
- time/server.h time/server.c
-endif
-
-if ALERTPLUGIN
-builtin_modules += alert
-builtin_sources += alert/main.c \
- alert/server.h alert/server.c
-endif
-
if HEALTHPLUGIN
builtin_modules += health
builtin_sources += health/hdp_main.c health/hdp_types.h \
@@ -237,13 +212,20 @@ builtin_sources += health/hdp_main.c health/hdp_types.h \
health/hdp_util.h health/hdp_util.c
endif
-if THERMOMETERPLUGIN
-builtin_modules += thermometer
+if GATTMODULES
+builtin_modules += thermometer alert time gatt_example proximity
builtin_sources += thermometer/main.c \
thermometer/manager.h thermometer/manager.c \
- thermometer/thermometer.h thermometer/thermometer.c
+ thermometer/thermometer.h thermometer/thermometer.c \
+ alert/main.c alert/server.h alert/server.c \
+ time/main.c time/server.h time/server.c \
+ plugins/gatt-example.c \
+ proximity/main.c proximity/manager.h proximity/manager.c \
+ proximity/monitor.h proximity/monitor.c \
+ proximity/reporter.h proximity/reporter.c
endif
+
builtin_modules += hciops mgmtops
builtin_sources += plugins/hciops.c plugins/mgmtops.c