summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorArik Nemtsov <arik@wizery.com>2012-04-02 22:12:40 +0300
committerJohan Hedberg <johan.hedberg@intel.com>2012-04-03 13:01:07 +0300
commita20e040fd5094c4eabe48f6112460d953fa4f7d0 (patch)
tree707406bd12bc85ffd66267231b06371b4b3c8657 /Makefile.am
parentdd4d0d6b653627d86319dcdf1c1efb5a46fa628c (diff)
proximity: link loss: implement link loss server
The profile is implemented in linkloss.[ch]. A GATT service is registered with read/write callbacks on the link-loss alert level attribute. The alert level is maintained per device. It is returned on read and updated on write. When the alert level is non-zero, a callback is registered on the disconnection of the remote device. If a device with non-zero alert state is disconnected, an appropriate PropertyChanged signal is emitted with the alert level previously set by the device. We avoid emitting a signal when the disconnection was requested by us.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index ddc28d2a7..12b3d8120 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -222,7 +222,8 @@ builtin_sources += thermometer/main.c \
plugins/gatt-example.c \
proximity/main.c proximity/manager.h proximity/manager.c \
proximity/monitor.h proximity/monitor.c \
- proximity/reporter.h proximity/reporter.c
+ proximity/reporter.h proximity/reporter.c \
+ proximity/linkloss.h proximity/linkloss.c
endif