summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorSzymon Janc <szymon.janc@tieto.com>2012-10-03 15:18:28 +0200
committerJohan Hedberg <johan.hedberg@intel.com>2012-10-03 22:44:15 +0300
commit94667c8290663eb79f4c6026fa5a278a89b6730d (patch)
treef7aa6d0c980da4e2b6202543afcfe5e5b53432a8 /Makefile.am
parent2640939604ce3c7d5c29c185962aceb3913c5737 (diff)
oob: Refactor oob callback handling and move it to adapter code
This allows oob plugin to register for callback after executing certain action on adapter. Currently reading local OOB data and pairing is supported. It should be easy to support more callbacks in future if needed e.g. powering on. Thanks to this plugin is not required to duplicate code that would validate adapter/device when callback is received as callback condition is check in adapter. It also allows to pass user data which will be provided back when cb is called further reducing plugin code.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 1 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index daa78d58d..1e53fa900 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -308,8 +308,7 @@ src_bluetoothd_SOURCES = $(gdbus_sources) $(builtin_sources) \
src/profile.h src/profile.c \
src/device.h src/device.c src/attio.h \
src/dbus-common.c src/dbus-common.h \
- src/event.h src/event.c \
- src/oob.h src/oob.c src/eir.h src/eir.c \
+ src/event.h src/event.c src/eir.h src/eir.c \
src/mgmt.c src/mgmt.h
src_bluetoothd_LDADD = lib/libbluetooth-private.la @GLIB_LIBS@ @DBUS_LIBS@ \
-ldl -lrt