summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSimon McVittie <simon.mcvittie@collabora.co.uk>2007-04-17 16:00:52 +0000
committerSimon McVittie <simon.mcvittie@collabora.co.uk>2007-04-17 16:00:52 +0000
commit1b83e6270f963e024b4dfa6bdf6660beb2e419ea (patch)
tree9f1834525c08152f14c98aa55984c7973e068b27 /configure.ac
parent88054dd8667fdeff1056dc8084a3384e5829d42c (diff)
Split telepathy-glib into stable and unstable parts
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index ffc2e53d4..5d41d1ca1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -65,6 +65,11 @@ AC_ARG_ENABLE(debug,
AC_HELP_STRING([--disable-debug],[compile without debug code]),
enable_debug=$enableval, enable_debug=yes )
+AC_ARG_ENABLE(unstable,
+ AC_HELP_STRING([--disable-unstable],
+ [don't build static library containing unstable interfaces]),
+ enable_unstable=$enableval, enable_unstable=yes )
+
AC_ARG_ENABLE(handle-leak-debug,
AC_HELP_STRING([--enable-handle-leak-debug],[compile with handle leak debugging code]),
enable_handle_leak_debug=$enableval, enable_handle_leak_debug=no )
@@ -113,6 +118,8 @@ AC_SUBST(COVERAGE_CFLAGS)
AC_SUBST([ENABLE_CODING_STYLE_CHECKS])
+AM_CONDITIONAL([ENABLE_UNSTABLE], [test $enable_unstable = yes])
+
dnl Endianness (for the sha1 implementation)
AC_C_BIGENDIAN