summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorTor Lillqvist <tml@iki.fi>2005-01-06 19:15:49 +0000
committerTor Lillqvist <tml@src.gnome.org>2005-01-06 19:15:49 +0000
commitbd77b4b4a91ef4dbedb9ce56ac66323f55c39608 (patch)
treee787c793dd22c1790144bea8b841bf8263956445 /configure.in
parentb687214a7cbc05a2603fe99e78e722c5d4d43108 (diff)
configure.in glib/Makefile.am Win32 cross-compilation fixes. (#163144, J.
2005-01-06 Tor Lillqvist <tml@iki.fi> * configure.in * glib/Makefile.am * gobject/Makefile.am: Win32 cross-compilation fixes. (#163144, J. Ali Harlow)
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 8083b7c39..35d31b19a 100644
--- a/configure.in
+++ b/configure.in
@@ -169,6 +169,11 @@ AC_SUBST(GTHREAD_DEF)
AC_SUBST(TESTGMODULE_EXP)
if test "$glib_native_win32" = "yes"; then
+ AC_CHECK_TOOL(NM, nm, no)
+ if [ "$NM" = no ]; then
+ AC_MSG_ERROR([*** Could not find an implementation of nm in your PATH.])
+ fi
+ AC_CHECK_TOOL(RANLIB, ranlib, :)
AC_CHECK_PROG(ms_librarian, [lib.exe], [yes], [no])
fi
AM_CONDITIONAL(MS_LIB_AVAILABLE, [test x$ms_librarian = xyes])