summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAlan Coopersmith <Alan.Coopersmith@sun.com>2005-11-13 01:41:50 +0000
committerAlan Coopersmith <Alan.Coopersmith@sun.com>2005-11-13 01:41:50 +0000
commitf9e6bc3588358c82c9d6e3293cc4eae28567959b (patch)
tree2f425e5393a53ce498628e387da08eb2aca458d2 /Makefile.am
parent9bccda24de3851829059c224ce94de28066bd8f5 (diff)
Install xdm man page using APP_MAN_SUFFIX instead of forcing .1
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am14
1 files changed, 10 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index 9dd4a18..728d81b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -88,12 +88,13 @@ endif
# xdm man page
#
-man1_MANS = xdm.man
+appmandir = $(mandir)/man$(APP_MAN_SUFFIX)
-CLEANFILES = $(man1_MANS)
+appman_SOURCES = xdm.man.cpp
+appman_DATA = $(appman_SOURCES:man.cpp=@APP_MAN_SUFFIX@)
-BUILT_SOURCES = $(man1_MANS)
-EXTRA_DIST = $(man1_MANS:man=man.cpp)
+CLEANFILES = $(appman_DATA)
+EXTRA_DIST = $(appman_SOURCES)
include $(top_srcdir)/cpprules.in
@@ -113,6 +114,11 @@ MANDEFS = \
CPP_FILES_FLAGS = $(MANDEFS) $(EXTRAMANDEFS)
+SUFFIXES += .$(APP_MAN_SUFFIX) .man.cpp
+
+.man.cpp.$(APP_MAN_SUFFIX):
+ $(RAWCPP) $(RAWCPPFLAGS) $(CPP_FILES_FLAGS) < $< | $(CPP_SED_MAGIC) > $@
+
#
# xdmshell
#