summaryrefslogtreecommitdiff
path: root/hw/kdrive/Makefile.am
diff options
context:
space:
mode:
authorDaniel Stone <daniel.stone@nokia.com>2006-07-19 16:51:04 -0400
committerDaniel Stone <daniels@endtroducing.fooishbar.org>2006-07-21 15:19:51 -0400
commit02d09105113fb9b560a770fe15f7bb041165831c (patch)
treecadb80dc7d1571d45481c316d1e8303bf5871b7c /hw/kdrive/Makefile.am
parenta274e7296b1bdd6f6c921f28b087610cec9548e0 (diff)
new KDrive input world order
Convert KDrive to GPE/GKE interface. Add first-class drivers and enumerate every device separately through Xi, instead of lamely attempting to aggregate them. Add XKB support to the Linux keyboard driver. Add 'thumb button' support to the tslib driver. Rejig InitInput, so each DDX has to add a list of drivers it supports. Support NewInputDeviceRequest, et al.
Diffstat (limited to 'hw/kdrive/Makefile.am')
-rw-r--r--hw/kdrive/Makefile.am8
1 files changed, 6 insertions, 2 deletions
diff --git a/hw/kdrive/Makefile.am b/hw/kdrive/Makefile.am
index c8832ebac..fa1dba90a 100644
--- a/hw/kdrive/Makefile.am
+++ b/hw/kdrive/Makefile.am
@@ -3,10 +3,14 @@ VESA_SUBDIRS = vesa ati chips epson i810 mach64 mga neomagic nvidia pm2 r128 \
smi via
endif
-if KDRIVEFBDEV
+if BUILD_KDRIVEFBDEVLIB
FBDEV_SUBDIRS = fbdev
endif
+if XFAKESERVER
+XFAKE_SUBDIRS = fake
+endif
+
if XSDLSERVER
XSDL_SUBDIRS = sdl
endif
@@ -22,7 +26,7 @@ SUBDIRS = \
$(FBDEV_SUBDIRS) \
$(VESA_SUBDIRS) \
$(XEPHYR_SUBDIRS) \
- fake
+ $(XFAKE_SUBDIRS)
DIST_SUBDIRS = vesa ati chips epson i810 mach64 mga neomagic nvidia pm2 r128 \
smi via fbdev sdl ephyr src linux fake sis300