summaryrefslogtreecommitdiff
path: root/hw/darwin/quartz/xpr/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'hw/darwin/quartz/xpr/Makefile.am')
-rw-r--r--hw/darwin/quartz/xpr/Makefile.am29
1 files changed, 29 insertions, 0 deletions
diff --git a/hw/darwin/quartz/xpr/Makefile.am b/hw/darwin/quartz/xpr/Makefile.am
new file mode 100644
index 000000000..7f2b008ec
--- /dev/null
+++ b/hw/darwin/quartz/xpr/Makefile.am
@@ -0,0 +1,29 @@
+noinst_LIBRARIES = libxpr.a
+AM_CFLAGS = @XORG_CFLAGS@ @DIX_CFLAGS@
+INCLUDES = @XORG_INCS@ \
+ -I$(srcdir) -I$(srcdir)/.. -I$(srcdir)/../.. \
+ -I$(top_srcdir)/miext/rootless/safeAlpha \
+ -I$(top_srcdir)/miext/rootless \
+ -I$(top_srcdir)/miext
+
+libxpr_a_SOURCES = \
+ appledri.c \
+ dri.c \
+ xprAppleWM.c \
+ xprCursor.c \
+ xprFrame.c \
+ xprScreen.c \
+ x-hash.c \
+ x-hook.c \
+ x-list.c
+
+xprbundledir = @APPLE_APPLICATIONS_DIR@/Resources/xpr.bundle/Contents/MacOS
+
+EXTRA_DIST = \
+ dri.h \
+ dristruct.h \
+ x-hash.h \
+ x-hook.h \
+ x-list.h \
+ Xplugin.h \
+ xpr.h