summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAlan Coopersmith <alan.coopersmith@sun.com>2007-11-20 18:27:12 -0800
committerAlan Coopersmith <alan.coopersmith@sun.com>2007-11-20 18:31:07 -0800
commit2f387d913aa76f1b6d21d8e2698be165301c6bc1 (patch)
tree2a912ab830c20ee6543050326f165c89dd561e65 /configure.ac
parentbe0cbe5a330f62cef47fffbc49e83b5e1637b7d0 (diff)
Enable use of /dev/urandom on Solaris as well
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 7 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 7d43216c8..f8c8fe403 100644
--- a/configure.ac
+++ b/configure.ac
@@ -172,12 +172,19 @@ b = bswap16(a);
fi
fi
+dnl Check to see if dlopen is in default libraries (like Solaris, which
+dnl has it in libc), or if libdl is needed to get it.
AC_CHECK_FUNC([dlopen], [],
AC_CHECK_LIB([dl], [dlopen], DLOPEN_LIBS="-ldl"))
case $host_os in
linux*)
AC_DEFINE(HAVE_URANDOM, 1, [Has /dev/urandom]) ;;
+ solaris*)
+ # Solaris 8 with patches, or Solaris 9 or later have /dev/urandom
+ if test -r /dev/urandom ; then
+ AC_DEFINE(HAVE_URANDOM, 1, [Has /dev/urandom])
+ fi ;;
*) ;;
esac
@@ -1314,9 +1321,6 @@ if test "x$XORG" = xyes -o "x$XGL" = xyes; then
XORG_CFLAGS="$XORGSERVER_CFLAGS -DHAVE_XORG_CONFIG_H"
XORG_LIBS="$COMPOSITE_LIB $FIXES_LIB $XEXTXORG_LIB $GLX_LIBS $RENDER_LIB $RANDR_LIB $DAMAGE_LIB $MIEXT_DAMAGE_LIB $MIEXT_SHADOW_LIB $XI_LIB $XKB_LIB $XPSTUBS_LIB"
-dnl Check to see if dlopen is in default libraries (like Solaris, which
-dnl has it in libc), or if libdl is needed to get it.
-
PKG_CHECK_MODULES([PCIACCESS], [pciaccess >= 0.8.0])
XORG_SYS_LIBS="$XORG_SYS_LIBS $PCIACCESS_LIBS $DLOPEN_LIBS $GLX_SYS_LIBS"
XORG_CFLAGS="$XORG_CFLAGS $PCIACCESS_CFLAGS"