summaryrefslogtreecommitdiff
path: root/tests/util/CMakeLists.txt
diff options
context:
space:
mode:
authorRafael Antognolli <rafael.antognolli@intel.com>2018-03-09 10:42:50 -0800
committerRafael Antognolli <rafael.antognolli@intel.com>2018-03-13 16:09:49 -0700
commitb8a4f6a0eb6bedf1b1d4eb845fabd0f6a635433a (patch)
tree3edc85390ffe3bbb6a0653e90c3548d27f36d54b /tests/util/CMakeLists.txt
parentdbbf87e969dd613bb5eae0066bfef99f944bce5b (diff)
cmake: Use WAYLAND_LDFLAGS instead of WAYLAND_LIBRARIES.
If the wayland library is found in a prefix, or some non-default place, WAYLAND_LIBRARIES will not contain -L<path to lib>, only the -lwayland-client part. If we want the whole set of flags, as returned by "pkg-config --libs wayland-client", we need to use WAYLAND_LDFLAGS instead. Signed-off-by: Rafael Antognolli <rafael.antognolli@intel.com> Reviewed-by: Dylan Baker <dylan@pnwbakers.com>
Diffstat (limited to 'tests/util/CMakeLists.txt')
-rw-r--r--tests/util/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/tests/util/CMakeLists.txt b/tests/util/CMakeLists.txt
index a9fc33900..0508eb030 100644
--- a/tests/util/CMakeLists.txt
+++ b/tests/util/CMakeLists.txt
@@ -155,7 +155,7 @@ if(${CMAKE_SYSTEM_NAME} MATCHES "Linux")
endif()
if(PIGLIT_HAS_WAYLAND)
- list(APPEND UTIL_GL_LIBS ${WAYLAND_LIBRARIES})
+ list(APPEND UTIL_GL_LIBS ${WAYLAND_LDFLAGS})
endif()
endif(${CMAKE_SYSTEM_NAME} MATCHES "Linux")