summaryrefslogtreecommitdiff
path: root/hw/xfree86/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'hw/xfree86/Makefile.am')
-rw-r--r--hw/xfree86/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/hw/xfree86/Makefile.am b/hw/xfree86/Makefile.am
index 418a35a83..8f1390596 100644
--- a/hw/xfree86/Makefile.am
+++ b/hw/xfree86/Makefile.am
@@ -105,6 +105,7 @@ if INSTALL_SETUID
chmod u+s $(DESTDIR)$(bindir)/Xorg
endif
if SUID_WRAPPER
+ $(MKDIR_P) $(DESTDIR)$(SUID_WRAPPER_DIR)
mv $(DESTDIR)$(bindir)/Xorg $(DESTDIR)$(SUID_WRAPPER_DIR)/Xorg.bin
${INSTALL} -m 755 Xorg.sh $(DESTDIR)$(bindir)/Xorg
-chown root $(DESTDIR)$(SUID_WRAPPER_DIR)/Xorg.wrap && chmod u+s $(DESTDIR)$(SUID_WRAPPER_DIR)/Xorg.wrap