summaryrefslogtreecommitdiff
path: root/hw/dmx/Makefile.am
diff options
context:
space:
mode:
authorBrian <brian@yutani.localnet.net>2006-09-23 10:35:25 -0600
committerBrian <brian@yutani.localnet.net>2006-09-23 10:35:25 -0600
commit945b7c63946f5257d0f9b0dcf2f8f4882fb2c6f8 (patch)
tree6136540fd8ece8bad03f5d41cfb862972dfb824d /hw/dmx/Makefile.am
parent891e9c3e6cbd0869a57395b96c8e18ff522c2bb4 (diff)
The fbcmap.c file used by Xdmx _must_ be compiled with XFree86Server defined.
Otherwise, Xdmx generates a slew of protocol errors.
Diffstat (limited to 'hw/dmx/Makefile.am')
-rw-r--r--hw/dmx/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/hw/dmx/Makefile.am b/hw/dmx/Makefile.am
index d36647b54..89136b904 100644
--- a/hw/dmx/Makefile.am
+++ b/hw/dmx/Makefile.am
@@ -16,6 +16,9 @@ GLX_INCS = -I$(top_srcdir)/hw/xfree86/dixmods/extmod \
GLX_DEFS = @GL_CFLAGS@
endif
+# It's essential that fbcmap.c be compiled with this flag for DMX to work!!
+DMX_CFLAGS = -DXFree86Server=1
+
if BUILDDOCS
SUBDIRS += doc
endif
@@ -86,6 +89,7 @@ Xdmx_CFLAGS = \
$(DIX_CFLAGS) \
$(GLX_INCS) \
$(GLX_DEFS) \
+ $(DMX_CFLAGS) \
@DMXMODULES_CFLAGS@
# Man page