summaryrefslogtreecommitdiff
path: root/hw/vfb/Makefile.am
diff options
context:
space:
mode:
authorGaetan Nadon <memsize@videotron.ca>2011-01-09 20:27:51 -0500
committerKeith Packard <keithp@keithp.com>2011-01-18 15:10:24 -0800
commit9240cffd659b1c13d66162200c6e384ea1cdbc44 (patch)
treef0e9861bb161b76a4718be85901aa20a61b23706 /hw/vfb/Makefile.am
parent3f4c71799b3164440624d09b7b631d3d3c0a29ef (diff)
Xvfb: build Xvfb man pages using XORG_MANPAGE_SECTIONS
Nothing requires the use of a C preprocessor Using standard file extensions (.man) means no need for .gitignore Use standard directory and makefile Fix trailing whitespaces Reviewed-by: Alan Coopersmith <alan.coopersmith@oracle.com> Reviewed-by: RĂ©mi Cardona <remi@gentoo.org> Signed-off-by: Gaetan Nadon <memsize@videotron.ca> Signed-off-by: Keith Packard <keithp@keithp.com>
Diffstat (limited to 'hw/vfb/Makefile.am')
-rw-r--r--hw/vfb/Makefile.am21
1 files changed, 2 insertions, 19 deletions
diff --git a/hw/vfb/Makefile.am b/hw/vfb/Makefile.am
index de5e1c5c9..ed46dbbc1 100644
--- a/hw/vfb/Makefile.am
+++ b/hw/vfb/Makefile.am
@@ -1,3 +1,5 @@
+SUBDIRS = man
+
bin_PROGRAMS = Xvfb
noinst_LIBRARIES = libfbcmap.a
@@ -28,24 +30,5 @@ Xvfb_LDADD = $(XVFB_LIBS) $(XVFB_SYS_LIBS) $(XSERVER_SYS_LIBS)
Xvfb_DEPENDENCIES = $(XVFB_LIBS)
Xvfb_LDFLAGS = $(LD_EXPORT_SYMBOLS_FLAG)
-# Man page
-include $(top_srcdir)/cpprules.in
-
-appmandir = $(APP_MAN_DIR)
-
-appman_PRE = Xvfb.man
-appman_DATA = $(appman_PRE:man=@APP_MAN_SUFFIX@)
-
-BUILT_SOURCES = $(appman_PRE)
-CLEANFILES = $(appman_PRE) $(appman_DATA)
-
-SUFFIXES += .$(APP_MAN_SUFFIX) .man
-
-.man.$(APP_MAN_SUFFIX):
- -$(AM_V_at)rm -f $@
- $(AM_V_at)$(LN_S) $< $@
-
-EXTRA_DIST = Xvfb.man.pre
-
relink:
$(AM_V_at)rm -f Xvfb$(EXEEXT) && $(MAKE) Xvfb$(EXEEXT)