summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAlan Coopersmith <Alan.Coopersmith@sun.com>2005-08-06 19:48:12 +0000
committerAlan Coopersmith <Alan.Coopersmith@sun.com>2005-08-06 19:48:12 +0000
commitb90a88e80310e5650e2abed4c151889d9c0bd316 (patch)
tree1778808b03dd6cf705dec0f0210ae2004ffa34ec /configure.ac
parent2304c14fe5d3796c557a86d0ece1f0fb92591469 (diff)
Add checks for functions used in os/access.c & os/connection.c:
getdtablesize(), getifaddrs(), getpeereid(), getpeerucred()
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 6dc178d8b..072462ca4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -71,6 +71,15 @@ AC_TYPE_PID_T
AC_FUNC_VPRINTF
AC_CHECK_FUNCS([geteuid getuid link memmove memset mkstemp strchr strrchr strtol getopt getopt_long vsnprintf walkcontext])
AC_FUNC_ALLOCA
+# Old HAS_* names used in os/*.c
+AC_CHECK_FUNC([getdtablesize], AC_DEFINE(HAS_GETDTABLESIZE,1,
+ [Define to 1 if you have the `getdtablesize' function.]))
+AC_CHECK_FUNC([getifaddrs], AC_DEFINE(HAS_GETIFADDRS,1,
+ [Define to 1 if you have the `getifaddrs' function.]))
+AC_CHECK_FUNC([getpeereid], AC_DEFINE(HAS_GETPEEREID,1,
+ [Define to 1 if you have the `getpeereid' function.]))
+AC_CHECK_FUNC([getpeerucred], AC_DEFINE(HAS_GETPEERUCRED,1,
+ [Define to 1 if you have the `getpeerucred' function.]))
AM_CONDITIONAL(NEED_VSNPRINTF, [test x$HAVE_VSNPRINTF = xno])