summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorbart <bart@a5019735-40e9-0310-863c-91ae7b9d1cf9>2009-08-26 18:11:18 +0000
committerbart <bart@a5019735-40e9-0310-863c-91ae7b9d1cf9>2009-08-26 18:11:18 +0000
commitd1f724c5724658fa19d71cb7c6cd5ad5e164e6aa (patch)
tree6c4ec9bd32511285a210c3ad8abbd0c984e3a196 /configure.in
parentfe83da6104523a2b355ba11c37c846ccdba59622 (diff)
Added regression tests that verify the following behavior:
- On Linux, whether Valgrind properly intercepts the system calls that access /proc/self/cmdline, /proc/<pid>/cmdline, /proc/self/exe and /proc/<pid>/exe. - On Darwin, whether Valgrind does not modify the behavior of the system calls that access the aforementioned files. git-svn-id: svn://svn.valgrind.org/valgrind/trunk@10871 a5019735-40e9-0310-863c-91ae7b9d1cf9
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index bd3df63e..fd5a4b57 100644
--- a/configure.in
+++ b/configure.in
@@ -1526,6 +1526,7 @@ AC_CHECK_FUNCS([ \
pthread_rwlock_timedrdlock \
pthread_rwlock_timedwrlock \
pthread_spin_lock \
+ readlinkat \
semtimedop \
signalfd \
sigwaitinfo \