summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBen Crocker <bcrocker@redhat.com>2017-06-02 19:37:55 -0400
committerEmil Velikov <emil.l.velikov@gmail.com>2017-06-28 08:20:45 +0100
commitc26be2b2e920b9e79067c9ffa51cc6f122a08743 (patch)
treee75a41d16dcde244856ab518a774572703bfbeff /configure.ac
parent74db56b97a65d488c38a8cfbb600b019439c2f91 (diff)
mapi: Enable assembly language API acceleration for PPC64LE (V2)
Implement assembly language API acceleration for PPC64LE, analogous to long-standing implementations for X86 and X86-64. See also similar implementation in libglvnd. Tested with Piglit. Signed-off-by: Ben Crocker <bcrocker@redhat.com> Acked-by: Emil Velikov <emil.velikov@collabora.com> Reviewed-by: Bill Schmidt <wschmidt@linux.vnet.ibm.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index c9dc51bc0d..7fade23b6a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -766,6 +766,13 @@ if test "x$enable_asm" = xyes; then
;;
esac
;;
+ powerpc64le)
+ case "$host_os" in
+ linux*)
+ asm_arch=ppc64le
+ ;;
+ esac
+ ;;
esac
case "$asm_arch" in
@@ -781,6 +788,10 @@ if test "x$enable_asm" = xyes; then
DEFINES="$DEFINES -DUSE_SPARC_ASM"
AC_MSG_RESULT([yes, sparc])
;;
+ ppc64le)
+ DEFINES="$DEFINES -DUSE_PPC64LE_ASM"
+ AC_MSG_RESULT([yes, ppc64le])
+ ;;
*)
AC_MSG_RESULT([no, platform not supported])
;;
@@ -2663,6 +2674,7 @@ AM_CONDITIONAL(HAVE_COMMON_OSMESA, test "x$enable_osmesa" = xyes -o \
AM_CONDITIONAL(HAVE_X86_ASM, test "x$asm_arch" = xx86 -o "x$asm_arch" = xx86_64)
AM_CONDITIONAL(HAVE_X86_64_ASM, test "x$asm_arch" = xx86_64)
AM_CONDITIONAL(HAVE_SPARC_ASM, test "x$asm_arch" = xsparc)
+AM_CONDITIONAL(HAVE_PPC64LE_ASM, test "x$asm_arch" = xppc64le)
AC_SUBST([NINE_MAJOR], 1)
AC_SUBST([NINE_MINOR], 0)