summaryrefslogtreecommitdiff
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorChris Bieneman <beanz@apple.com>2016-03-02 00:27:14 +0000
committerChris Bieneman <beanz@apple.com>2016-03-02 00:27:14 +0000
commitd702b73a426e82cb0e3fa62b399a799be61798ac (patch)
tree1699c95982d2b1d351748e41a352947c61c9f78f /test/CMakeLists.txt
parentc26136be88b5c48ae5a186ce676f112d57cc8791 (diff)
[CMake] Add convenience target llvm-test-depends to build test dependencies.
This is useful when paired with the distribution targets to build prerequisites for running tests. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@262428 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index e7c26f6e9b5..1e053041f57 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -113,6 +113,8 @@ if(LLVM_BUILD_EXAMPLES)
)
endif()
+add_custom_target(llvm-test-depends DEPENDS ${LLVM_TEST_DEPENDS})
+
add_lit_testsuite(check-llvm "Running the LLVM regression tests"
${CMAKE_CURRENT_BINARY_DIR}
PARAMS llvm_site_config=${CMAKE_CURRENT_BINARY_DIR}/lit.site.cfg