summaryrefslogtreecommitdiff
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorPeter Collingbourne <peter@pcc.me.uk>2014-09-10 22:20:49 +0000
committerPeter Collingbourne <peter@pcc.me.uk>2014-09-10 22:20:49 +0000
commit3f93a546c26f30e28b593243578fa24df5ff69df (patch)
tree02bda667fc2f827d41702fdb00b4905472e24984 /test/CMakeLists.txt
parent257e85e7c2939e3cb61da1b9c647487194d7014e (diff)
Add LLVMgold target to test dependencies.
git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@217557 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index 2b3a618a3ae..f20bc950385 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -60,6 +60,10 @@ if( LLVM_USE_INTEL_JITEVENTS )
set(LLVM_TEST_DEPENDS ${LLVM_TEST_DEPENDS} llvm-jitlistener)
endif( LLVM_USE_INTEL_JITEVENTS )
+if(TARGET LLVMgold)
+ set(LLVM_TEST_DEPENDS ${LLVM_TEST_DEPENDS} LLVMgold)
+endif()
+
add_lit_testsuite(check-llvm "Running the LLVM regression tests"
${CMAKE_CURRENT_BINARY_DIR}
PARAMS llvm_site_config=${CMAKE_CURRENT_BINARY_DIR}/lit.site.cfg