summaryrefslogtreecommitdiff
path: root/spice-video-dummy/src/Makefile.am
diff options
context:
space:
mode:
authorJeremy White <jwhite@codeweavers.com>2019-03-15 16:12:16 -0500
committerJeremy White <jwhite@codeweavers.com>2019-05-03 10:41:07 -0500
commit0980d14bd07d6cd66824482d23f6cc2fca2438ec (patch)
treebeca8877bf90e1851e11ea9280ab1c7e53ac7a95 /spice-video-dummy/src/Makefile.am
parent744a9fc023cc4f6fe94d011a695802b404f92578 (diff)
Add the upstream xf86-video-dummy as of November 25, 2018.
This gives x11spice access to a modern virtual/offscreen frame buffer driver for the Xorg X server. We will then make slight revisions to make it more suitable for use with Spice. The overall result should be a more functional stack, as compared to the existing xf86-video-qxl driver, as we gain a wide range of Mesa features for free. It also simplifies the overall process. This is from https://gitlab.freedesktop.org/xorg/driver/xf86-video-dummy as of 850c0516.
Diffstat (limited to 'spice-video-dummy/src/Makefile.am')
-rw-r--r--spice-video-dummy/src/Makefile.am39
1 files changed, 39 insertions, 0 deletions
diff --git a/spice-video-dummy/src/Makefile.am b/spice-video-dummy/src/Makefile.am
new file mode 100644
index 0000000..c0d82e0
--- /dev/null
+++ b/spice-video-dummy/src/Makefile.am
@@ -0,0 +1,39 @@
+# Copyright 2005 Adam Jackson.
+#
+# Permission is hereby granted, free of charge, to any person obtaining a
+# copy of this software and associated documentation files (the "Software"),
+# to deal in the Software without restriction, including without limitation
+# on the rights to use, copy, modify, merge, publish, distribute, sub
+# license, and/or sell copies of the Software, and to permit persons to whom
+# the Software is furnished to do so, subject to the following conditions:
+#
+# The above copyright notice and this permission notice (including the next
+# paragraph) shall be included in all copies or substantial portions of the
+# Software.
+#
+# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+# IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+# FITNESS FOR A PARTICULAR PURPOSE AND NON-INFRINGEMENT. IN NO EVENT SHALL
+# ADAM JACKSON BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER
+# IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN
+# CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
+
+
+# this is obnoxious:
+# -module lets us name the module exactly how we want
+# -avoid-version prevents gratuitous .0.0.0 version numbers on the end
+# _ladir passes a dummy rpath to libtool so the thing will actually link
+# TODO: -nostdlib/-Bstatic/-lgcc platform magic, not installing the .a, etc.
+
+AM_CFLAGS = $(XORG_CFLAGS) $(PCIACCESS_CFLAGS)
+
+dummy_drv_la_LTLIBRARIES = dummy_drv.la
+dummy_drv_la_LDFLAGS = -module -avoid-version
+dummy_drv_la_LIBADD = $(XORG_LIBS)
+dummy_drv_ladir = @moduledir@/drivers
+
+dummy_drv_la_SOURCES = \
+ compat-api.h \
+ dummy_cursor.c \
+ dummy_driver.c \
+ dummy.h