summaryrefslogtreecommitdiff
path: root/src/vulkan/Makefile.am
diff options
context:
space:
mode:
authorEmil Velikov <emil.velikov@collabora.com>2017-02-28 18:53:04 +0000
committerEmil Velikov <emil.l.velikov@gmail.com>2017-02-28 18:53:04 +0000
commitca7d2025a7547275101efbca0b45adb67f8fa59d (patch)
tree8fb0fbc0c67efe47a9c9e6a3ab9b1469e62e3e6f /src/vulkan/Makefile.am
parent14281c9035d6b30cda08fd6ab573ee3bfafa2c2d (diff)
vulkan: provide vk.xml as argument to the python generator
Do not hardcode the file in the python script, but pass it via the build system(s). The latter is the only one that should know about the file location/tree structure. Cc: Dylan Baker <dylan@pnwbakers.com> Signed-off-by: Emil Velikov <emil.velikov@collabora.com> Reviewed-by: Jason Ekstrand <jason@jlekstrand.net> Reviewed-by: Eric Engestrom <eric.engestrom@imgtec.com>
Diffstat (limited to 'src/vulkan/Makefile.am')
-rw-r--r--src/vulkan/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/vulkan/Makefile.am b/src/vulkan/Makefile.am
index e28a81c8cf..f7aca8e937 100644
--- a/src/vulkan/Makefile.am
+++ b/src/vulkan/Makefile.am
@@ -16,7 +16,7 @@ BUILT_SOURCES = \
util/vk_enum_to_str.c util/vk_enum_to_str.h: util/gen_enum_to_str.py $(vulkan_api_xml)
$(MKDIR_GEN)
- $(PYTHON_GEN) $(srcdir)/util/gen_enum_to_str.py --outdir $(top_builddir)/src/vulkan/util
+ $(PYTHON_GEN) $(srcdir)/util/gen_enum_to_str.py --xml $(vulkan_api_xml) --outdir $(top_builddir)/src/vulkan/util
libvulkan_util_la_SOURCES = $(VULKAN_UTIL_GENERATED_FILES)