summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTobias Droste <tdroste@gmx.de>2016-11-19 02:39:06 +0100
committerEmil Velikov <emil.l.velikov@gmail.com>2016-12-05 14:43:47 +0000
commitc702369bf514cf08ec5699e5be15badb069d6e96 (patch)
tree2485764887e5b11ec980b04a0d16f49a7e22e17f /configure.ac
parent62f4e6f2726c34357e274fcc1ef934f96c498ba2 (diff)
configure.ac: Move LLVM ac_subst closer to usage
This moves llvm_set_environment_variables to its final destination and moves all the LLVM AC_SUBST() below the function call. No functional change. Signed-off-by: Tobias Droste <tdroste@gmx.de> Reviewed-by: Emil Velikov <emil.velikov@collabora.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac29
1 files changed, 14 insertions, 15 deletions
diff --git a/configure.ac b/configure.ac
index 0a82dda7c1..22fcc212da 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1018,6 +1018,19 @@ radeon_llvm_check() {
fi
}
+llvm_set_environment_variables
+
+AC_SUBST([MESA_LLVM])
+AC_SUBST([LLVM_BINDIR])
+AC_SUBST([LLVM_CFLAGS])
+AC_SUBST([LLVM_CPPFLAGS])
+AC_SUBST([LLVM_CXXFLAGS])
+AC_SUBST([LLVM_LIBDIR])
+AC_SUBST([LLVM_LIBS])
+AC_SUBST([LLVM_LDFLAGS])
+AC_SUBST([LLVM_INCLUDEDIR])
+AC_SUBST([LLVM_VERSION])
+
dnl Options for APIs
AC_ARG_ENABLE([opengl],
[AS_HELP_STRING([--disable-opengl],
@@ -1167,8 +1180,6 @@ AC_ARG_ENABLE([gallium-tests],
[enable_gallium_tests="$enableval"],
[enable_gallium_tests=no])
-llvm_set_environment_variables
-
# Option for Gallium drivers
# Keep this in sync with the --with-gallium-drivers help string default value
@@ -1375,8 +1386,6 @@ if test "x$enable_gallium_osmesa" = xyes; then
fi
fi
-AC_SUBST([MESA_LLVM])
-
# SHA1 hashing
AC_ARG_WITH([sha1],
[AS_HELP_STRING([--with-sha1=libc|libmd|libnettle|libgcrypt|libcrypto|libsha1|CommonCrypto|CryptoAPI],
@@ -2144,23 +2153,13 @@ fi
AM_CONDITIONAL(HAVE_CLOVER, test "x$enable_opencl" = xyes)
AM_CONDITIONAL(HAVE_CLOVER_ICD, test "x$enable_opencl_icd" = xyes)
AC_SUBST([OPENCL_LIBNAME])
+AC_SUBST([CLANG_RESOURCE_DIR])
dnl
dnl Gallium configuration
dnl
AM_CONDITIONAL(HAVE_GALLIUM, test -n "$with_gallium_drivers")
-AC_SUBST([LLVM_BINDIR])
-AC_SUBST([LLVM_CFLAGS])
-AC_SUBST([LLVM_CPPFLAGS])
-AC_SUBST([LLVM_CXXFLAGS])
-AC_SUBST([LLVM_LIBDIR])
-AC_SUBST([LLVM_LIBS])
-AC_SUBST([LLVM_LDFLAGS])
-AC_SUBST([LLVM_INCLUDEDIR])
-AC_SUBST([LLVM_VERSION])
-AC_SUBST([CLANG_RESOURCE_DIR])
-
case "x$enable_opengl$enable_gles1$enable_gles2" in
x*yes*)
EGL_CLIENT_APIS="$EGL_CLIENT_APIS "'$(GL_LIB)'