summaryrefslogtreecommitdiff
path: root/hw/xfree86/dummylib/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'hw/xfree86/dummylib/Makefile.am')
-rw-r--r--hw/xfree86/dummylib/Makefile.am13
1 files changed, 2 insertions, 11 deletions
diff --git a/hw/xfree86/dummylib/Makefile.am b/hw/xfree86/dummylib/Makefile.am
index ab62a6b54..6299a1ff7 100644
--- a/hw/xfree86/dummylib/Makefile.am
+++ b/hw/xfree86/dummylib/Makefile.am
@@ -2,25 +2,16 @@
# libdummy-nonserver.a contains additional routines normally found in the
# server for use in building the utilities like scanpci & the config tools
-noinst_LIBRARIES = libdummy.a libdummy-nonserver.a
+noinst_LIBRARIES = libdummy-nonserver.a
INCLUDES = $(XORG_INCS)
-AM_CFLAGS = $(XORG_CFLAGS) @SERVER_DEFINES@ @LOADER_DEFINES@
+AM_CFLAGS = $(DIX_CFLAGS) $(XORG_CFLAGS)
if NEED_STRLCAT
STRL_SRCS = $(top_srcdir)/os/strlcat.c $(top_srcdir)/os/strlcpy.c
endif
-libdummy_a_SOURCES = getvalidbios.c getemptypci.c \
- pcitestmulti.c xf86allocscripi.c \
- xf86addrestolist.c xf86drvmsg.c xf86drvmsgverb.c \
- xf86getverb.c \
- xf86opt.c xf86screens.c xf86servisinit.c xf86verbose.c \
- #xf86errorf.c xf86errorfverb.c xf86msg.c xf86msgverb.c \
- #logvwrite.c verrorf.c xf86info.c xalloc.c fatalerror.c \
- #$(srcdir)/../os-support/shared/sigiostubs.c
-
libdummy_nonserver_a_SOURCES = \
fatalerror.c \
getvalidbios.c \