summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDodji Seketeli <dodji@openedhand.com>2007-11-07 18:48:23 +0100
committerDodji Seketeli <dodji@openedhand.com>2007-11-07 18:48:23 +0100
commit26e1fc7b42de850d69fba89703ffddd36480b997 (patch)
treeccbcd216dee1fb3f680e69a2c1269921c10634b4 /configure.ac
parent950f9995d11aff2c51139b34fb27eba594f2bd20 (diff)
Xephyr: don't use Xv or GL when those are disabled.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index df70ae931..1b4580127 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1855,10 +1855,13 @@ if test "$KDRIVE" = yes; then
XEPHYR_DRI=no
if test x$XEPHYR = xyes -a x$DRI = xyes; then
XEPHYR_DRI=yes
+ XEPHYR_DRI_LIBS=-lGL
+ AC_SUBST(XEPHYR_DRI_LIBS)
fi
if test x$XEPHYR_DRI = xyes ; then
AC_DEFINE(XEPHYR_DRI,1,[enable DRI extension in xephyr])
fi
+ AM_CONDITIONAL(XEPHYR_HAS_DRI, [test x$XEPHYR_DRI = xyes])
# Xephyr needs nanosleep() which is in librt on Solaris
AC_CHECK_FUNC([nanosleep], [],