summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorBehdad Esfahbod <behdad@behdad.org>2006-07-11 17:27:08 -0400
committerBehdad Esfahbod <behdad@behdad.org>2006-07-11 17:27:08 -0400
commit94bdbc15f79308269f1bcd74b3d8899f8458babc (patch)
tree93b35b6dd720c320e3e01aefad5311cb2b884efa /Makefile.am
parentc45a9321759e5cc0fcf6eda85f91d09ebb4db0d2 (diff)
Improve test suite build infrastructure
- Add new target recheck, that checks only failed tests - Add targets test and retest, and make html after (re)checking - Make targets html and index.html lazy, only update if any tests changed - Improve build system such that checking one test (using TESTS=...) doesn't build all tests - Remove pixman-rotate from XFAIL
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 131af9cf..7855fd6f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,9 +1,11 @@
DIST_SUBDIRS = pixman src test doc
SUBDIRS = pixman src doc
-.PHONY: doc
+.PHONY: doc test
doc:
-$(MAKE) -C doc doc
+test:
+ -$(MAKE) -C test test
# libpng is required for our test programs
if CAIRO_HAS_PNG_FUNCTIONS