summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRan Benita <ran234@gmail.com>2012-01-18 00:03:16 +0200
committerDavid Herrmann <dh.herrmann@googlemail.com>2012-01-28 12:20:04 +0100
commit83dd9a6cfaa54bb006c9e5f5e1a3627e2f19af40 (patch)
tree40c409725c8166ac968b050878645cc7534bb3d4 /configure.ac
parent5cc56b8e3ca4d549be80d121c39f6affcb488285 (diff)
build: depend on xproto explicitly
Currently it's required by xkbcommon. However, we will need it for other backends as well, even with xkbcommon support disabled. xproto consisted only of static header files. We use the XK_ keysym definitions. It is therefore only required during compilation and we shouldn't needlessly duplicate it ourselves. Signed-off-by: Ran Benita <ran234@gmail.com> Signed-off-by: David Herrmann <dh.herrmann@googlemail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 176fef1..c60ab07 100644
--- a/configure.ac
+++ b/configure.ac
@@ -56,6 +56,10 @@ PKG_CHECK_MODULES([UDEV], [libudev])
AC_SUBST(UDEV_CFLAGS)
AC_SUBST(UDEV_LIBS)
+PKG_CHECK_MODULES([XPROTO], [xproto])
+AC_SUBST(XPROTO_CFLAGS)
+AC_SUBST(XPROTO_LIBS)
+
PKG_CHECK_MODULES([XKBCOMMON], [xkbcommon])
AC_SUBST(XKBCOMMON_CFLAGS)
AC_SUBST(XKBCOMMON_LIBS)