summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDavid Herrmann <dh.herrmann@googlemail.com>2012-05-05 17:16:13 +0200
committerDavid Herrmann <dh.herrmann@googlemail.com>2012-05-05 17:16:13 +0200
commit380868d54bdaf993cc7f7d6e8a3bf590ebf91a6c (patch)
treedd931b5c0513bff5545904bfbc97360519fc0b61 /configure.ac
parent23e9903f0737ffd61f54669ce66af2d60ce4a31b (diff)
uterm_monitor: add system monitor for full seat support
The new uterm_monitor watches the system for seat-changes and puts all devices under the correct seat. This allows to run kmscon on multiple seats in a single process. It now also correctly handles seat-changes, that is, devices that are reattached to a different seat on runtime. It is not integrated into the kmscon source, yet, but will soon be. Signed-off-by: David Herrmann <dh.herrmann@googlemail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index bcb6be8..68ce36c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -22,6 +22,10 @@ AM_PROG_AR
LT_PREREQ(2.2)
LT_INIT
+PKG_CHECK_MODULES([SYSTEMD], [libsystemd-login])
+AC_SUBST(SYSTEMD_CFLAGS)
+AC_SUBST(SYSTEMD_LIBS)
+
PKG_CHECK_MODULES([DRM], [libdrm])
AC_SUBST(DRM_CFLAGS)
AC_SUBST(DRM_LIBS)