summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDavid Herrmann <dh.herrmann@googlemail.com>2012-08-08 19:01:53 +0200
committerDavid Herrmann <dh.herrmann@googlemail.com>2012-08-08 19:11:42 +0200
commite1bf9c5c196bff9f134a553dbc6f7a92864109ff (patch)
tree1bdc9869ff09234ab64e53ea18c4f168618a2929 /Makefile.am
parentc677377e0447efdd0aeb5128ded7c614651951a1 (diff)
uterm: video: drm: implement .blit, .blend and .fill callbacks
This implements the static 2D blitting callbacks for the DRM backend. It uses OpenGL to push the images with textures through the rendering pipeline. Please note that this is horribly slow when used like 2D blitting. However, it is a safe backend and better than nothing. Signed-off-by: David Herrmann <dh.herrmann@googlemail.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 6 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index 1b9ebca..413ae67 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -83,10 +83,12 @@ endif
#
SHADERS = \
- src/output_shader_def.vert \
- src/output_shader_def.frag \
- src/output_shader_tex.vert \
- src/output_shader_tex.frag
+ src/static_fill.vert \
+ src/static_fill.frag \
+ src/static_blend.vert \
+ src/static_blend.frag \
+ src/static_blit.vert \
+ src/static_blit.frag
EXTRA_DIST += \
$(SHADERS)